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Welcome back!

Questions?
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Gathering Dynamic Data

▶ Instrumentation and Software Probes
▶ Example: Performance profiler

▶ Simulation (or Emulation)
▶ Example: CPU simulator

▶ Hardware Probes
▶ Example: Hardware Performance Counters
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Automatic Performance Measurement

▶ [Software Probes] Profiler:
▶ Interrupts program during execution
▶ Examines call stack

▶ [Software Probes] Operating System Perf. Counters:
▶ Count important system events (network accesses etc.)

▶ Simulator:
▶ Simulates CPU/Memory in software
▶ Tries to replicate inner workings of machine
▶ Alternatively: Emulator (= replicate only observable

functionality, not internals)
▶ [Hardware Probes] CPU:

▶ Hardware performance counters count interesting events
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Profiler

▶ Measures: which functions are we spending
our time in?

▶ Approach:
▶ Build stack maps
▶ Execute program, interrupt regularly
▶ During interrupt:

▶ Examine program counter
▶ Examine stack

▶ Infer callers from stack contents

Execution Stack
return (old-1)

$fp (old-1)
. . .
. . .

return (old-2)
$fp (old-2)

. . .

Source of inaccuracy: inlined functions don’t track their
caller on call stack
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Simulator

RAM

Input
devices CPU Output

devices

Rest of the world

memory.c

input.c cpu.c output.c

Rest of the world

▶ Software simulates hardware components
▶ Can count events of interest (memory accesses etc.)

Modern CPUs are very complex: Simulators are
inaccurate in practice
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Hardware Performance Counters (1/2)
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Hardware Performance Counters (2/2)

Special CPU registers:
▶ Count performance events
▶ Registers must be configured to collect specific performance

events
▶ Number of CPU cycles
▶ Number of instructions executed
▶ Number of memory accesses

. . .
▶ #performance event types > #performance registers

May be inaccurate: not originally built for software
developers
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Summary

▶ Performance analysis may require detailed dynamic data
▶ Profiler: Probes stack contents at certain intervals
▶ Simulator:

▶ Simulates hardware in software, measures
▶ Tends to be inaccurate

▶ Performance Counters:
▶ Software:

▶ Operating System counts events of interest
▶ Hardware:

▶ Special registers can be configured to measure CPU-level events
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Gathering Dynamic Data

▶ Instrumentation and Software Probes
▶ Simulation
▶ Hardware Probes
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Generality of Performance
Measurements?

Measured performance properties are valid for. . .
▶ Selected CPU
▶ Selected operating system
▶ Compiler version and configuration
▶ Operating system configuration:

▶ OS setup
(e.g., dynamic scheduler)

▶ Processes running in parallel
. . .

▶ A particular input/output setup
▶ Behaviour of attached devices
▶ Time of day, temperature, air pressure, . . .

▶ CPU configuration (CPU frequency etc.)
. . .
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Unexpected Effects

▶ User toddm measures run time 0.6s
▶ User amer measures run time 0.8s
▶ Both measurements are stable
▶ Reason for discrepancy:

▶ Before program start, Linux copies shell environment onto stack
▶ Shell environment contains user name
▶ Program is loaded into different memory addresses

⇒ Memory caches can speed up memory access in one case
but not the other

Changing your user name can speed up code
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Unexpected Effects

Mytkowicz, Diwan, Hauswirth, Sweeney: “Producing wrong data
without doing anything obviously wrong”, in ASPLOS 2009
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Linking Order
Is there a difference between re-ordering modules in RAM?
gcc a.o b.o -o program (Variant 1)
gcc b.o a.o -o program (Variant 2)

(Mytkowicz, Diwan, Hauswirth, Sweeney, ASPLOS’09)
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Adaptive Systems
▶ Java program: loop n iterations (x axis) around simple

computation that randomly samples from pre-initialised array
▶ Measurement: 11 runs

▶ Ran each n 11 times, time reported below is last iteration only
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Warm-Up Effects
▶ Performance varies during initial runs
▶ Eventually reaches steady state
▶ Reason: Adaptive Systems

▶ Hardware:
▶ Cache: Speed up some memory accesses
▶ Branch Prediction: Speed up some jumps
▶ Translation Lookaside Buffer

▶ Software:
▶ Operating System / Page Table
▶ Operating System / Scheduler
▶ Just-in-Time compiler

▶ Understanding performance: what to measure?
▶ Latency: measure first run

Reset system before every run
▶ Throughput: later runs

Discard initial n measurements
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Ignored Parameters

▶ Performance affected by subtle effects
▶ Systems developers must “think like researchers” to spot

potential influences

Beware of generalising measurement results!
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Summary

▶ Modern computers are complex:
▶ Caches make memory access times hard to predict
▶ Multi-tasking may cause sudden interruptions
▶ CPU frequency scaling changes speed based on temperature

. . .
▶ This makes measurements difficult:

▶ Must carefully consider what assumptions we are making
▶ Must measure repeatedly to gather distribution
▶ Must check for warm-up effects
▶ Must try to understand causes for performance changes

▶ Measurements are often not normally distributed
▶ Mean + Standard Deviation may not describe samples well
▶ If in doubt, use box plots or violin plots
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Dynamic Program Analysis:
Applications

Like static analysis, dynamic analysis can help:
▶ Understanding
▶ Efficiency
▶ Safety
▶ Security
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Application: Program Understanding

Approaches:
▶ Performance analysis (gprof, papi, perf, . . . )
▶ Interactive debugging (gdb, jdb, . . . )
▶ Tracing

Compute sequence of actions (trace) of interest
▶ Methods
▶ Parameters
▶ IL/assembly instructions
▶ Lines of code

. . .
▶ Dynamic slicing

Reduce program to parts that were actually executed
▶ Remove dead code
▶ Enables further optimisations (e.g., inlining)
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Tracing vs. Dynamic Slicing
Source programSource program

(0)int f(int x) {
(1) return x + 1;
(2)}
(3)int g(int x) {
(4) return x - 1;
(5)}

(3)int g(int x) {
(4) return x - 1;
(5)}
(6) void main() {
(7) int x = f(1);
(8) int y = f(2);
(9) if (x < 0) {
(A) puts("fail");
(B) } else {
(C) printf("%d",x+y);
(D) }
(E)}

TraceTrace

6
7
0[x=1]
1[⇒2]
8
0[x=2]
1[⇒3]
9
B
C

Dynamic SliceDynamic Slice
(0)int f(int x) {
(1) return x + 1;
(2)}

(6)void main() {
(7) int x = f(1);
(8) int y = f(2);

(C) printf("%d",x+y);

(E)}

Tracing/slicing algorithms vary in output 21 / 49



Application: Efficiency

▶ Dynamic Optimisation
▶ Utilise run-time knowledge to optimise

▶ Speculative Optimisation
▶ Type or value seems to be constant?

▶ Speculate: it is constant
▶ Optimise accordingly

▶ Add guard: is assumption correct?
▶ Deoptimise when guard fails
▶ Common example: method inlining

▶ Challenge: Dynamic analysis introduces overhead
▶ Focus efforts on hot methods (frequently running)
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Application: Safety

▶ Dynamic type checking
▶ Out-of-bounds checks

a[i]
▶ Narrowing conversions

Object obj = . . . ;
String str = (String) obj;

▶ Assertions
▶ Preconditions

Checked before subroutine call
▶ Postconditions

Checked at end of subroutine call
▶ Invariants

Checked between subroutine calls in same module / object
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Application: Security

▶ Which part of program are not trustworthy?
▶ Externally loaded code?
▶ Externally obtained data?
▶ Runtime environment?

▶ Untrusted code:
▶ Confine (containers, sandboxing)
▶ Analysis mainly to detect “bad behaviour”

▶ Untrusted data:
▶ Sanitise, track
▶ Beware: can escalate to untrusted code
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Sandboxing: Confining Untrusted Code

Untrusted Program

OS Kernel (may be emulated by VM)

Restricted
HD

Restricted
RAM

Sandbox

Restricted permissions
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Summary

▶ Dynamic analysis contributes techniques to all typical clients
of program analysis

▶ Understanding:
▶ Interactive debugging
▶ Tracing and Dynamic Slicing

▶ Efficiency:
▶ Dynamic and speculative optimisation

▶ Safety:
▶ Dynamic type checking
▶ Dynamic assertion checking

▶ Security:
▶ Dynamic Taint analysis
▶ Alternative to analysis: Sandboxing, i.e., executing in

restricted execution environment
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Some Examples
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Tainted Values (1/2)

Python
username = request.GET[’user’]
...
q = sql.query("SELECT * from Users WHERE name=’"

+ username + "’")
user_data = q.run

© Randall Munroe, xkcd.com. CC BY-NC 2.5
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Tainted Values (2/2)

C
int parse_package(s* out, uint8* data) {

char username[9] = { 0 };
int username_len = data[0];
// spec says: length <= 8
memcpy(username, data+1, username_len);
...

}

StackStack

ret parse_package
username_len

0 0 0 0
0 0 0 0
0

memcpy locals
. . .

’m’ ’y’ ’n’ ’a’
’m’ ’e’

username
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Tainted Values (2/2)

C
int parse_package(s* out, uint8* data) {

char username[9] = { 0 };
int username_len = data[0];
// spec says: length <= 8
memcpy(username, data+1, username_len);
...

}

StackStack

ret parse_package
username_len= 6

0 0 0 0
0 0

0 0
0

ret memcpy
memcpy locals

. . .

’m’ ’y’ ’n’ ’a’
’m’ ’e’
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Tainted Values (2/2)

C
int parse_package(s* out, uint8* data) {

char username[9] = { 0 };
int username_len = data[0];
// spec says: length <= 8
memcpy(username, data+1, username_len);
...

}

StackStack

ret parse_package
username_len=16

0 0 0 0
0 0 0 0
0

memcpy locals
. . .

’m’ ’y’ ’n’ ’a’
’m’ ’e’
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Tracing ‘Tainted’ Values

Taint Analysis:
▶ Track tainted values
▶ Remove taint if values are sanitised
▶ Detect if they reach sensitive sinks
▶ NB: Static taint analysis may also be possible

Unsafe inputUnsafe input
▶ Taint source: Network ops
▶ Sanitiser: SQL string escape
▶ Taint sink: SQL query string

Leaking secretsLeaking secrets
▶ Taint source: Plaintext passwd.
▶ Sanitiser: cryptographic hash
▶ Taint sink: Network ops
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Dynamic Taint Analysis

query_l = "SELECT ...’" query_l = "SELECT ..."ϵ

query_r = "’" query_r = "’"ϵ

username = request.GET[’user’] username = "..."t

...
query_str = query_l + username query_str = "..."t

query_str = query_str + query_r query_str = "..."t

q = sql.query(query_str) Fault!
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Dynamic Taint Analysis

Strategy:
▶ Annotate tainted values with taint tags or shadow values

s = read_network() // string in s will be tainted
t = "foo" + "bar" // string in t will be untainted

▶ Extend operators to propagate taint:
⊕ ϵ t
ϵ ϵ t
t t t

"foo"v [1] = "o"v

"foo"v+"bar"w = "foobar"v⊕w

▶ Check taint sinks for tainted input
▶ Needs instrumentation (shadow values) or explicit support by

runtime (e.g., Perl, Ruby)
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Conditionals

▶ Should conditionals propagate taint?
▶ Usually such control dependencies don’t propagate taint

Python
if secret_password == ’’:

network_send(’Account disabled, cannot log in’);
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Attackers vs. Taint Ananlysis

Is taint analysis ‘sound enough’ to detect attempts
to expose sensitive data?
▶ Attackers can subvert this analysis via control dependencies:

C
for (i = 0; i < 16; ++i) {

for (k = 0; k < 8; ++k) {
if (secret_password[i] & 1 << k) {

network_send("Meaninless Message");
} else {

network_send("Something Else");
}

} }
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System Command Attack

C
char d_secret[1024];
strcpy(d_secret, "/tmp/");
strcat(d_secret, secret); // taint d_secret

int iopipes[2];
pipe(iopipes);
...
if (fork()) { // create child process

// connect pipes
execv("/bin/rm", d_secret); // call external ’rm’

}
char[1024] buf; // untained!
read(iopipes[0], ...); // read output from ’rm’

System call will print e.g.:
rm: cannot remove ’/tmp/mysecretstring’: No such file or
directory
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Side Channel Attacks

Many more attacks possible:
▶ Timing attacks:

▶ Two threads
▶ One sends signal to other, with delays
▶ Delay loop length dependent on secret

▶ File length attack:
▶ Write dummy file
▶ File length (or other metadata) encodes secret

▶ Graphics buffer attack:
▶ Write to screen
▶ Read back with OCR
▶ Or adjust widget position / font size to encode secret
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Summary

▶ Dynamic taint analysis tracks tainted values
(from taint sources)

▶ Tags also referred to as shadow values
▶ Removes taint if values are sanitised
▶ Detects attempts to use tainted values in taint sinks
▶ Still many weaknesses in analysis:

▶ Control-dependence attacks
▶ System command attacks
▶ Side-channel attacks

▶ Can be strengthened with symbolic techniques
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Dynamic Binary Analysis

▶ Binary Analysis: Analyse binary executables
▶ Applicable to any executable program
▶ Only requires binary code
▶ Unaware of source language

▶ Dynamic Binary Analysis
▶ Analyser runs concurrently with program-under-analysis
▶ Can adaptively instrument / analyse / intercede
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Dynamic Binary Instrumentation (1/3)

Input Code

Instrumentation
Instrument

Copy-and-Annotate
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Dynamic Binary Instrumentation (2/3)

Input CodeIntermediate Representation

Instrumentation

Resynthesise

Disassemble

Disassemble-and-Resynthesise
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Dynamic Binary Instrumentation (3/3)

▶ Copy-and-Annotate (e.g., pin):
▶ Inserts code into binary
▶ Inserted code must maintain state (registers!)

▶ Disassemble-and-Resynthesise (e.g., valgrind, qemu):
▶ Decomposes program into IR
▶ Instrumentation on IR-level
▶ Easier/faster to track shadow values in some cases

▶ Shadow registers
▶ Shadow memory
▶ Must model system calls for proper tracking
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Application: Finding Memory Errors

▶ Reads from uninitialised memory in C can trigger undefined
behaviour

▶ Approach: Track information: which bits are uninitialised?
▶ Requires shadow registers, shadow values
▶ Almost every instruction must be instrumented

Shadow values Program

short x;x:
x:
x:

x |= 0x7;
if (x & 0x10) {
. . .
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Example: Valgrind’s Memcheck

▶ Valgrind is Disassemble-and-Resynthesise-style Binary
Instrumentation tool

▶ Memcheck: tracks memory initialisation (mostly) at bit level
▶ Less precise for floating point registers

▶ Valgrind uses dynamic translation:
▶ Translate & instrument blocks of code at address until return /

branch
▶ Instrumented code jumps back into Valgrind core for lookup /

new translation

43 / 49



Challenges

▶ System calls
▶ System calls may affect shadow values (e.g., propagate

taintedness)
▶ Must be modelled for precision

▶ Self-modifying code
▶ Used e.g. in GNU libc
▶ Must be detected, force eviction of old code (expensive checks!)
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Valgrind

▶ Binary instrumenter
▶ Open Source
▶ Many supported hardware / OS combinations
▶ Analyses (focus on Simulation):

▶ Call analysis
▶ Cache analysis
▶ Memcheck

. . .
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Qemu

▶ Binary instrumenter and translator
▶ Open Source
▶ Focus on emulation
▶ Runs kernel + user space
▶ Translate from one ISA to another (e.g., run ARM on

ADM64)
▶ Emulates system:

▶ Graphics, networking, sound, input devices, USB, . . .
▶ Almost two dozen platforms supported
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Summary

▶ Binary instrumentation is a form of low-level dynamic
analysis

▶ Two main schemes:
▶ Copy-and-Annotate: insert new code
▶ Disassemble-and-Resynthesise: merge analysis subject code

with annotation code
▶ Shadow values supported through shadow registers and

shadow memory
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Summary: Dynamic Analysis

▶ Collecting Measurements of Characteristics at Events via
Probes:
▶ In software, hardware, or indirectly via simulation

▶ Applications include:
▶ Purely to observe (program understanding etc.)
▶ Efficiency (JIT compilation etc.)
▶ Prevent undesirable behaviour (Safety, Security)

▶ Sampling to reduce overhead:
▶ Finite set of inputs/workloads, hardware etc.

▶ Some characteristics (esp. performance) influenced by sources
of variability outside of program and program input

▶ Can usually avoid false positives, cannot usually avoid false
negatives
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Outlook

▶ Oral exam information / registration up on Tuesday
▶ Next Lecture: Review session– bring your questions!

http://cs.lth.se/edap15
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