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Refaktorisering och UML med Eclipse 3.5.1

1 Introduktion

Eclipse är en utvecklingsmiljö för allehanda uppgifter. Den inneh̊aller bland annat ett mycket
kvalificerat stöd för programutveckling i Java. Den är särskilt lämplig för denna kurs eftersom
det är lätta att göra designförändringar och det finns integrerade verktyg för design med UML.

Eclipse är utformat som ett ramverk s̊a att man enkelt kan lägga till ny funktionalitet med
”stickproppar” (plug–ins) som man kan hitta p̊a nätet eller skriva själv. Propparna inneh̊aller
i regel kompilerade Java–klasser som implementerar gränssnitt i ramverket. Även Java–miljön
ing̊ar i systemet som stickproppar. I denna laboration skall du installera en stickpropp fr̊an nätet
för att kunna modellera med hjälp av UML.

Det kommer löpande nya versioner av Eclipse och proppar som inte alltid fungerar tillsammans.
För detta läs̊ar rekommenderas version Eclipse 3.5.1.

Eclipse är implementerat i Java och kan därmed exekveras p̊a olika plattformar och finns b̊ade p̊a
Linux- och Windows-maskinerna i EFD. Användarens konfigurationsfiler h̊aller reda p̊a var Java
Runtime Environment finns p̊a datorn vilket kräver omkonfiguration om man byter plattform i
EFD-systemet. Du bör inledningsvis använda Linux.

2 Konfiguration

Programmet startas via applikationsmenyn (Applications→Programming→Eclipse).

Det är lämpligt att skapa ett nytt arbetsomr̊ade (workspace) för denna kurs. När du startar
Eclipse f̊ar du eventuellt tillfälle att välja arbetsomr̊ade i en dialogruta. Om s̊a inte är fallet
öppnar du dialogrutan via menyvalet File→Switch Workspace. Ange en sökväg som t. ex.
slutar med omd/workspace. Eclipse skapar de kataloger som inte finns.

Sedan öppnas en välkomstsida som inneh̊aller ikoner som leder till omfattande dokumentation,
handledningar och nyheter. Om du inte använt Eclipse tidigare ger steg-för-steg-handledningen
bakom ikonen Tutorials→Create a Hello World Application en kort introduktion.

Det finns ett 40-tal eclipse-baserade verktyg för att modellera med UML, se t.ex. http://www.
eclipseplugincentral.com. Det verktyg vi använt tidigare år finns inte längre i n̊agon fri
version s̊a vi m̊aste byta. Jag vet inte vilket som är bäst och studenter brukar ha olika preferen-
ser. Beskrivningen i detta dokument använder Green UML, http://green.sourceforge.net.
Green UML är tämligen primitivt och kan bara användas för klassdiagram. Förhoppningsvis du-
ger det för användning i denna kurs, men knappast i kommersiella sammanhang. Det är till̊atet
att använda valfritt datorbaserat verktyg för att producera UML-diagram. Om n̊agon hittar
n̊agot som är riktig bra vill jag gärna bli informerad.

Du skall själv konfigurera Ecplise för att kunna använda UML-verktyget. Under menyalterna-
tivet Help→ Install new software skall du lägga till tv̊a plugins. Välj Add fyller i Location
med http://download.eclipse.org/tools/gef/updates/releases. Följ anvisningarna tills
installationen är klar. Välj den senaste releasen. Det tar flera minuter att installera denna plu-
gin. Det är förmodligen onödigt att starta om eclipse innan man installerat nästa plugin.

Gör sedan samma sak med http://www.cse.buffalo.edu/faculty/alphonce/green. Välj att
installera Green men inte Green Add-Ons

1



Det är lämpligt att ändra inställningarna för Green UML under Preferences→Green åtminstone
s̊a att bara Generate stubs for abstract methods och Save compilation units är mar-
kerade. I Preferences→Green→Class Boxes bör Show method names och Show tooltips
vara markerade.

3 Java-editorn

Standard-editorn för Java kan väldigt mycket av spr̊aket och rapporterar hela tiden fel och är be-
redd att hjälpa till p̊a olika sätt. Fel markeras med v̊agstrecksunderstrykning och ett erbjudande
om hjälp indikeras med en liten glödlampa i vänsterkanten.

Om man skriver början p̊a ett reserverat ord eller ett namn och därefter CTRL-mellanslag s̊a
kommer editorn att föresl̊a ett antal alternativ. Efter ”wh” ges fyra alternativ för while-satser
och n̊agra klassnamn som du förmodligen inte hört talas om. Genom att flytta sig till alternativen
kan man f̊a se hur Eclipse kommer att komplettera. Man accepterar med return eller dubbelklick.
Editorn känner ocks̊a till namn p̊a dina egna variabler, metoder och klasser.

Man kan skriva main och f̊a en hel main-metod och sysout för System.out.println(). Ett
tos p̊a en plats där man kan definiera metoder ger som första alternativ att skugga meto-
den toString. Mallarna finns i Windows→Preferences→Java →Editor→Templates
där man själv kan modifiera och lägga till.

När man skriver en punkt efter ett objektnamn erbjuds ocks̊a ett antal alternativ. Antalet
reduceras allteftersom man skriver vidare.

Om man skriver x=1; utan att ha deklarerat x visar editorn en liten lampa som erbjuder att
deklarera en lokal variabel, lägga till ett attribut eller en parameter. När lampan är dekorerad
med ett litet kryss finns det fel som m̊aste åtgärdas. Ett utropstecken betyder ofta att n̊agot är
onödigt och kan tas bort utan att programmets funktionalitet förändras.

4 Menyer och genvägar

Det finns ofta flera sätt att anropa en operation.

De flesta operationerna kan n̊as via huvudmenyerna, File, Edit, etc. Många av operationerna
förutsätter att man markerat det element som skall p̊averkas. Om man inte gjort kan alternativet
vara nedtonat eller saknas.

En del operationer har egna ikoner under raden med huvudmenyer.

Editorer och vyer har ofta egna verktygsikoner.

Genom att högerklicka p̊a ett element öppnar man elementets kontextmeny. Om man vill att
operationen skall gälla alla element i editorn skall man se till att inget element är markerat och
högerklicka i bakgrunden.

En del kommandon har tangentbordsgenvägar. S̊adana syns till höger i vanliga menyer.

Mycket g̊ar att konfigurera efter eget skön, t ex via Window→Preferences→General→
Keys och Window→Customize Perspective. . . . Inställningar kan sparas, exporteras och
importeras.
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5 Source-menyn

Med Source→Format formatteras programmet s̊a att indenteringen, inskjutna mellanslag,
tomma rader etc. blir konsekvent. Det g̊ar att i detalj styra hur detta skall g̊a till i Windows→
Preferences→Java→Codestyle→Formatter om man inte är nöjd med skönsvärdena.

Medlemmarna i en klass (attribut, metoder, klasser etc.) bör vara ordnade p̊a samma sätt i alla
klasser i ett projekt. Med Source→Sort members åstadkommer man detta i en klass, ett pa-
ket eller i hela projektet. Via Windows→Preferences→Java→Appearance→Member
Sort Order kan man styra detaljer för sorteringen.

När man behöver en ny konstruerare som ger värden åt n̊agra attribut använder man med fördel
Source→Generate Constructor using Fields.

Source→Organize imports sorterar import-klausuler, tar bort onödiga och lägger till s̊adana
som behövs.

Med Source→Clean Up . . . f̊ar man en mer genomgripande städning av programmet med in-
dentering, sortering, mm. Detaljerna kan styras via Windows→Preferences→Java→Code
Style→Clean Up.

6 Refactor-menyn

Refactor-menyn inneh̊aller mängd operationer för att omstrukturera programmet. Inneh̊allet i
menyn växlar efter vad som är markerat i Package Explorer eller editorer.

Namnbyten, Refactor→Rename . . . , är en enkel och kraftfull operation. Om man byter
namn p̊a en klass kommer alla referenser till namnet i hela projektet att bytas ut. Om man s̊a
önskar kommer även liknande namn p̊a attribut och metoder och förekomster i kommentarer
att modifieras.

Det enklaste sättet att flytta klasser mellan olika paket är att dra dem i Package Explorer. Det
g̊ar att flytta metoder och attribut p̊a samma sätt, men det kräver ofta efterarbete.

I uppgiften nedan f̊ar du prova n̊agra andra operationer. Experimentera gärna; i regel g̊ar det
att återställa programmet med Edit→Undo.

7 Green UML

UML-modellen är integrerad med Java-representationen av programmet s̊a att förändringar i
den ena i regel avspeglar sig i den andra. Java-filer m̊aste sparas för att detta skall hända. Om
UML-modellen inte är uppdaterad finns kommandot Refresh Editor i bildens kontextmeny
eller kortkommandot f.

Det kan vara bekvämt att skapa klasser och gränssnitt med UML-editorns palett, men undvik att
skapa associationer; verktyget skapar de associerade objekten med parameterlösa konstruerare.
Detta är nästan alltid fel.

Programmet saknar automatisk layout-funktion. Det är inte alltid s̊a lätt att f̊a diagrammet att
se ut exakt som man skulle önska. Ansträng dig inte mer än att diagrammet blir användbart
som underlag för designdiskussionen.
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8 Uppgift

Denna uppgift inneh̊aller enkel objektorienterad design och introducerar de viktigaste handgrep-
pen i Eclipse.

1. Starta eclipse med ett nytt arbetsomr̊ade (workspace) för denna kurs.

2. Installera och konfigurera UML-verktyget.

3. Skapa ett nytt Java-projekt (geometry) via .

4. Skapa ett nytt Java-paket (element) med .

5. Öppna ett nytt UML-diagram med hjälp av kontextmenyn för paketet genom att välja
Green UML→Add to New Class Diagram. Motsvarande fil f̊ar namn efter projektet.
Det kan vara lämpligt att namnge det efter paketet för att underlätta när det blir flera
paket

6. Skapa klassen Point i UML-diagrammet genom att markera i UML-paletten och
klicka p̊a den plats i diagrammet där klassrutan skall placeras. Motsvarande Java-klass
dyker upp i Package Explorer.

7. Gör en JavaDoc-kommentar för klassen via Source→Generate element comment.

8. Lägg till tv̊a privata attribut, x och y, av typen double i Java-editorn. När man sparar
filen kommer attributen att bli synliga i UML-diagrammet.

9. Skapa en konstruktor med de tv̊a attributen via Source→Generate Constructor Using
Fields. Kryssa gärna i Omit call to default constructor super().

10. Lägg till metoden public double distanceTo(Point other) i Java-editorn och l̊at den
returnera avst̊andet mellan this och other. Gör en JavaDoc-kommentar för metoden.

11. Formattera klassen med Source→Format.

12. Gör en JUnit-test för distanceTo via File→New→JUnit Test Case. Följ anvis-
ningen att lägga till JUnit-paketet i ”build path”. Lägg till en metod som använder
assertEqual(). Exekvera testet med Run As→ JUnit Test.

13. Skapa ett nytt paket för tester och flytta testklassen dit. Testa igen.

14. Vi skall nu ändra modellen s̊a att den kan hantera punkter och segment antingen i 2 eller
3 dimensioner. Byt namn p̊a Point till Point2D via Refactor→Change Name.

15. Extrahera ett gränssnitt fr̊an Point2D med metoden distanceTo via Refactor→Extract
Interface. L̊at gränssnittet f̊a namnet Point.

16. Ändra signaturen för distanceTo med Refactor→Change Signature s̊a att argumentet
f̊ar typen Point. Korrigera Point2D.

17. Skapa en klass Point3D med tre koordinater genom att utg̊a fr̊an en kopia av Point2D.

18. Infoga Point3D i UML-diagrammet genom att välja Green UML→Add to Last Vi-
ewed Class Diagram i kontextmenyn.

19. Skapa en klass, Segment, som representerar en sträcka med hjälp av dess ändpunkter.
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20. Implementera metoden double length() i Segment s̊a att den returnerar sträckans längd.

21. Testa metoden.

22. Använd Source→Clean Up. . . p̊a hela paketet. Markera Use costum profile och kon-
figurera efter egna önskem̊al, t ex genom att avmarkera Add missing Annotations under
fliken Missing Code och markera de fyra rutorna under fliken Code Organization.

23. Under Linux g̊ar det för närvarande inte att göra utskrifter direkt fr̊an eclipse. Detta
är ett pinsamt fel som funnits alltför länge. Java-kod skriver man lämpligen ut via ett
terminalfönster i källkodskatalogen. UML-diagram g̊ar att exportera p̊a tv̊a olika former:
jpg och gif, via Save As.

24. Orientera dig om vad som kan konfigureras i Window→Preferences.

När uppgiften är färdig bör UML-diagrammet se ut ungefär s̊a här.

9 Redovisning

Ingen redovisning skall lämnas för laborationen och det är möjligt att utföra den p̊a egen hand.
Den som vill göra laborationen hemma kan ladda ned programvaran fr̊an nätet enligt anvisningar
p̊a kurshemsidan.
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